Status of the Internet Computer

Dashboard and API Stats are not Updating
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 02:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2021 - 01:53 UTC
Investigating
We are currently investigating this issue.
Posted Oct 21, 2021 - 01:16 UTC
This incident affected: IC Dashboard (IC API, Dashboard).