Status of the Internet Computer

NNS Dapp is loading 50x's for people
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Nov 26, 2022 - 23:50 UTC
Update
We are continuing to investigate this issue.
Posted Nov 26, 2022 - 20:28 UTC
Investigating
We are currently investigating this issue.
Posted Nov 26, 2022 - 20:04 UTC
This incident affected: Core System Canisters (NNS).