Status of the Internet Computer

Public dashboard is loading slowly
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Dec 06, 2022 - 17:45 UTC
Investigating
https://dashboard.internetcomputer.org/ is loading slowly. We're investigating.
Posted Dec 06, 2022 - 16:34 UTC
This incident affected: Community services (Public Dashboard, Public Dashboard API).