Status of the Internet Computer

Issues with hardware wallets on the NNS Front End Dapp
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Jan 12, 2022 - 10:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 12, 2022 - 09:33 UTC
This incident affected: NNS Front End Dapp.