Status of the Internet Computer

Investigating issue with x33ed subnet
Incident Report for InternetComputer
Resolved
The subnet has been upgraded and the issue is resolved.
Posted Nov 29, 2022 - 20:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 29, 2022 - 18:21 UTC
Investigating
We are currently investigating this issue.
Posted Nov 29, 2022 - 18:21 UTC
This incident affected: Internet Computer.