Status of the Internet Computer

Neuron Staked charts issue

Incident Report for InternetComputer

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 20:57 UTC

Investigating

On the ICP Dashboard, the Staked charts on the Neurons page are currently displaying some incorrect values due to how the underlying data is interpreted. The issue is being investigated.
Posted Jul 23, 2025 - 21:41 UTC
This incident affected: Community services (Public Dashboard, Public Dashboard API).