Status of the Internet Computer

Impaired dashboard statistics

Incident Report for InternetComputer

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 19:22 UTC

Monitoring

Fix has been implemented, monitoring as the metrics recover.
Posted Aug 20, 2025 - 17:33 UTC

Identified

Some items on the Internet Computer dashboard are currently unavailable. We are have investigated and identified the underlying issues and are working toward a fix now.
Posted Aug 20, 2025 - 16:28 UTC
This incident affected: Community services (Public Dashboard, Public Dashboard API).