Status of the Internet Computer

ICP Dashboard Maintenance
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Jun 14, 2024 - 00:18 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 13, 2024 - 15:19 UTC
Investigating
The Dashboard Team is performing maintenance on the ICP Dashboard and associated APIs from 1530 UTC to 1730 UTC. This maintenance window will not impact the IC.
Posted Jun 13, 2024 - 15:16 UTC
This incident affected: Community services (Public Dashboard, Public Dashboard API).