Status of the Internet Computer

Reduced NNS Finalization Rate
Incident Report for InternetComputer
Resolved
This incident has been resolved, finalization rate is back to normal, and delayed neuron rewards have been distributed.
Posted Jun 15, 2022 - 02:47 UTC
Update
We are continuing to investigate this issue.
Posted Jun 14, 2022 - 16:28 UTC
Investigating
We are experiencing lower than usual finalization rate on the NNS subnet. This causes slower ICP transactions and II authentications. We are investigating the issue. Maturity distributions are delayed due to the incident, which is expected to take place once the incident is resolved.
Posted Jun 14, 2022 - 16:28 UTC
This incident affected: Internet Computer and Core System Canisters (NNS).