Status of the Internet Computer

ICA Network Status Dashboard does not display current data.
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Oct 18, 2021 - 21:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2021 - 13:17 UTC
Update
We are continuing to investigate this issue.
Posted Oct 18, 2021 - 08:15 UTC
Investigating
We are currently investigating this issue.
Posted Oct 18, 2021 - 08:13 UTC
This incident affected: IC Dashboard (IC API, Dashboard).