Status of the Internet Computer

Experiencing Higher than Normal Traffic
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Jan 09, 2024 - 18:10 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 09, 2024 - 14:00 UTC
Identified
IC is currently experiencing a surge of traffic that is causing the dashboard and other pages to load slowly.
Posted Jan 09, 2024 - 11:12 UTC
This incident affected: Internet Computer.