Status of the Internet Computer

IC Network Dashboard and API Degraded Performance
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted May 10, 2022 - 19:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 10, 2022 - 16:35 UTC
Investigating
We are investigating high load on the IC Network Dashboard API resulting in degraded performance.
Posted May 10, 2022 - 15:11 UTC
This incident affected: IC Dashboard (IC API, Dashboard).