Status of the Internet Computer

Dashboard API Performance and errors
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 04:16 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 09, 2022 - 20:05 UTC
Investigating
We are currently investigating this issue.
Posted Jun 09, 2022 - 19:30 UTC
This incident affected: IC Dashboard (IC API, Dashboard).