Status of the Internet Computer

Subnet brlsh experiences higher latency on update calls
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 17:27 UTC
Investigating
Subnet `brlsh` is experiencing higher latency on update calls recently due to increased load on it. The team is investigating what kind of improvements can be made and will follow up with any changes in the coming weeks to address the situation.
Posted Jan 07, 2025 - 13:36 UTC
This incident affected: Internet Computer.