Status of the Internet Computer

Dashboard errors

Incident Report for InternetComputer

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 12:13 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 12:12 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 12:09 UTC

Identified

Posted Nov 18, 2025 - 12:09 UTC

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 12:07 UTC
This incident affected: Community services (Public Dashboard, Public Dashboard API).