Status of the Internet Computer

Experiencing Higher than Normal Traffic
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Jan 08, 2024 - 20:00 UTC
Identified
We are currently experiencing a surge of traffic that is causing the dashboard to load slowly.
Posted Jan 08, 2024 - 16:42 UTC
This incident affected: Community services (Public Dashboard).