Status of the Internet Computer

System subnet tdb26 experiencing intermittent finalization rate drops: dashboard metrics are delayed
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Jun 07, 2024 - 20:44 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 07, 2024 - 17:44 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 07, 2024 - 17:41 UTC
Identified
Identified intermittent finalization drops of the tdb26 system subnet. This impacts the NNS and ledger canisters.
Posted Jun 07, 2024 - 17:37 UTC
Update
We are continuing to investigate this issue.
Posted Jun 07, 2024 - 17:33 UTC
Investigating
Dashboard metrics shown are delayed, we are currently investigating and monitoring.
Posted Jun 07, 2024 - 17:32 UTC
This incident affected: Community services (Public Dashboard) and Core System Canisters (ICP Ledger, NNS, Internet Identity).