Status of the Internet Computer

XRC has exceeded current memory limit

Incident Report for InternetComputer

Resolved

As of https://dashboard.internetcomputer.org/proposal/139107, the XRC is healthy once again.
Posted Oct 27, 2025 - 21:24 UTC

Identified

A memory leak has been identified in the exchange rate canister, a fix is being implemented.
Posted Oct 27, 2025 - 20:15 UTC
This incident affected: Internet Computer.