Status of the Internet Computer

Subnet `x33ed` has low finalization rate
Incident Report for InternetComputer
Resolved
This incidents was resolved. More details will follow.
Posted Nov 13, 2023 - 16:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
More details will follow up.
Posted Nov 13, 2023 - 16:18 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 13, 2023 - 15:05 UTC
Investigating
We are currently investigating this issue.
Posted Nov 13, 2023 - 13:21 UTC
This incident affected: Internet Computer.