Status of the Internet Computer

Some metrics not updating

Incident Report for InternetComputer

Resolved

This incident has been resolved.
Posted Jul 20, 2025 - 00:48 UTC

Investigating

We are currently investigating why select metrics are not currently updating on the Dashboard. This does not appear to indicate anything is non-functioning on the Internet Computer.
Posted Jul 19, 2025 - 06:07 UTC
This incident affected: Community services (Public Dashboard, Public Dashboard API).