Status of the Internet Computer

Subnet "k44f" is experiencing intermittent finalization rate drops.
Incident Report for InternetComputer
Resolved
This incident has been resolved by proposal: https://dashboard.internetcomputer.org/proposal/40332
Posted Jan 18, 2022 - 10:42 UTC
Identified
Subnet "k44f" is experiencing intermittent finalization rate drops. We are working on the fix.
Posted Jan 14, 2022 - 13:33 UTC
This incident affected: Internet Computer.