Status of the Internet Computer

Public dashboard isn't showing any proposals
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Feb 10, 2022 - 16:26 UTC
Investigating
We're investigating an issue with the public dashboard that stopped listing all proposals. In case you need to see all open proposals please use the NNS frontend Dapp.
Posted Feb 10, 2022 - 15:12 UTC
This incident affected: Community services (Public Dashboard).