Status of the Internet Computer

Multiple subnets are experiencing a degraded performance
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Sep 08, 2021 - 13:11 UTC
Investigating
We are currently investigating this issue.
Posted Sep 08, 2021 - 10:05 UTC
This incident affected: Internet Computer and NNS Front End Dapp.