Status of the Internet Computer

Incorrect locations displayed on IC Network Dashboard Subnet Page
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted May 23, 2022 - 22:33 UTC
Investigating
We are currently investing an issue on the IC Network Dashboard API that returns every IC location when querying for Subnet level locations.
Posted May 23, 2022 - 18:49 UTC
This incident affected: Community services (Public Dashboard, Public Dashboard API).