Status of the Internet Computer

Safari users can be locked out of their Internet Identity
Incident Report for InternetComputer
Resolved
Internet Identity users are now required to set up multiple devices and provided additional recovery options.
Posted May 24, 2021 - 15:08 UTC
Update
An alternative solution for Safari users to secure their account is being worked on.
Posted May 23, 2021 - 23:08 UTC
Update
An alternative solution for Safari users to secure their account is being worked on.
Posted May 21, 2021 - 07:17 UTC
Monitoring
Internet Identity users are warned to set up multiple devices to avoid potentially losing access to their account. Support teams are working on additional solutions.
Posted May 19, 2021 - 20:55 UTC
Identified
Support teams have identified the issue and are investigating possible solutions. We're advising users to set up multiple devices while we find a more permanent solution.
Posted May 19, 2021 - 00:00 UTC
Investigating
Internet Identity users who authenticate using FaceID or TouchID and then Clear History and Website Data also delete their credentials and potentially lose access to their account. We're advising users to set up multiple devices while we investigate a more permanent solution.
Posted May 17, 2021 - 22:28 UTC
This incident affected: Internet Computer.