Status of the Internet Computer

NNS Frontend Dapp isn't loading
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Oct 21, 2022 - 16:17 UTC
Investigating
We are currently investigating this issue.
Posted Oct 21, 2022 - 15:10 UTC
This incident affected: NNS Front End Dapp.