Status of the Internet Computer

Dashboard Pages slow to load
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Jan 26, 2024 - 17:57 UTC
Investigating
We are currently investigating why certain pages are slow to load on the Dashboard. We apologize for any inconvenience.
Posted Jan 26, 2024 - 15:29 UTC
This incident affected: Community services (Public Dashboard).