Status of the Internet Computer

Degraded performance on app subnet pjljw
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 13:59 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2021 - 13:13 UTC
Investigating
We are currently investigating this issue.
Posted Nov 18, 2021 - 07:32 UTC
This incident affected: Internet Computer.