Status of the Internet Computer

Delayed proposal population on the IC Network Dashboard
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Apr 20, 2022 - 18:14 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 20, 2022 - 17:36 UTC
Monitoring
We have identified an issue on the IC Network Dashboard that prevented new proposals from being displayed and updated in a timely manner. The issue has been identified and a fix has been deployed.
Posted Apr 20, 2022 - 17:35 UTC
This incident affected: IC Dashboard (IC API, Dashboard).