Status of the Internet Computer

The https://internetcomputer.org/ domain is suspended.
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Nov 05, 2022 - 13:14 UTC
Identified
The domain registration for https://internetcomputer.org/ administratively suspended. We are actively working on resolving the issue.
Posted Nov 05, 2022 - 09:11 UTC
This incident affected: Community services (Public Dashboard, Public Dashboard API).