Status of the Internet Computer

Cloudflare outage induced dashboard errors

Incident Report for InternetComputer

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 02:46 UTC

Monitoring

There is an ongoing Cloudflare issue that is intermittently impacting the Dashboard and Dashboard APIs:

https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 12:32 UTC
This incident affected: Community services (Public Dashboard, Public Dashboard API).