Status of the Internet Computer

Failures in NNS DApp
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Aug 20, 2021 - 08:42 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 20, 2021 - 08:41 UTC
Identified
End users may experience issues on the NNS DApp when voting on proposals and managing neurons.

We've identified the problem and are working on rolling out a fix.
Posted Aug 19, 2021 - 22:45 UTC
This incident affected: NNS Front End Dapp.