Status of the Internet Computer

Finalization rate on subnet 5kdm2 dropped.
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 15:23 UTC
Update
Subnet 5kdm2 is now fully operational.
Posted Jul 19, 2021 - 15:21 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 19, 2021 - 09:20 UTC
Investigating
Finalization rate on subnet 5kdm2 dropped. The issue is being investigated.
Posted Jul 19, 2021 - 06:52 UTC
This incident affected: Internet Computer.