Status of the Internet Computer

Degraded Performance and Intermittent Errors
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Mar 18, 2022 - 21:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results
Posted Mar 18, 2022 - 21:16 UTC
Investigating
We are currently investigating this issue.
Posted Mar 18, 2022 - 20:31 UTC
This incident affected: Internet Computer and NNS Front End Dapp.