Status of the Internet Computer

Internet Identity Login Issues with New Chrome Version
Incident Report for InternetComputer
Resolved
This incident has been resolved.
Posted Aug 28, 2023 - 10:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 25, 2023 - 07:57 UTC
Investigating
Some Chrome users might experience a minor degradation with the latest version of Chrome due to the flakiness in a dependency used by the agent-js library. This can cause problems when using some IC apps. It’s not easy to reproduce consistently and it also doesn’t affect all Chrome users even in the same combination of Chrome version, Operating System version and CPU arch.
The fix for agent-js was released, it is recommended to upgrade agent-js (see this forum post https://forum.dfinity.org/t/upgrade-agent-js-to-resolve-a-chrome-issue/22364), and proposals to upgrade II and NNS dapp to the new version of the agent-js are coming soon (see the corresponding forum thread https://forum.dfinity.org/t/if-you-are-having-intermittent-issues-using-ii-and-the-nns-dapp-with-recent-chrome-versions-read-on/22365).
Posted Aug 25, 2023 - 07:57 UTC
This incident affected: Core System Canisters (Internet Identity).